Page tree
Skip to end of metadata
Go to start of metadata

When installing SHRINE from scratch, we generally recommend these minimum requirements for best performance, as these are the conditions that we test the software in:



MinimumRecommended
Operating SystemRPM-based LinuxCentOS 7 Core

Web Browser

Google Chrome 74Google Chrome 83 or better
Processor2 cores4 or more cores
Memory4GB8GB
Hard Drive Space30GB100GB
Java JDK

Any JDK version "11.0.6" 2020-01-14 LTS

OpenJDK 64-Bit Server VM Zulu11.37+17-CA

Apache Tomcat8.5.398.5.41
MariaDB5.5

Ver 15.1 Distrib 5.5.64-MariaDB

i2b2 Version1.7.12a

1.7.12a


For i2b2 1.7.12a - we have observed a lot of success with i2b2's "quick install" option. If you have not yet installed i2b2 1.7.12a please consider that path first.

Do not install SHRINE and i2b2 on the same operating system. Both SHRINE's Tomcat and i2b2's Wildfly servers are optimized to make maximum use of the operating system's resources. Either can starve the other for processing time or memory to the point of stalling both systems.

We strongly advise that you avoid placing SHRINE behind an application proxy. Misconfigured application proxies frequently interfere with SHRINE's networking needs. They offer no benefits in a SHRINE network and make troubleshooting very difficult. If you must run an application proxy, we ask that you configure your proxy to not intercept or modify any of SHRINE's network traffic.