Page tree
Skip to end of metadata
Go to start of metadata

For SHRINE to work properly, we recommend having at least Java JDK 1.8.0_202 installed. This will ensure that the underlying framework is in place for the SHRINE applications to function correctly. To setup Java's JDK, please follow these steps (running as the shrine / root user):

$ mkdir -p /opt/java
$ cd /opt/java
 
$ wget https://catalyst-artifacts.s3.amazonaws.com/jdk-8u202-linux-x64.tar.gz
 
$ tar xzf jdk-8u202-linux-x64.tar.gz
  
$ chown -R root: jdk1.8.0_*
  
-- for JAVA (in case you have another version of Java installed)
$ alternatives --install /usr/bin/java java /opt/java/jdk1.8.0_202/bin/java 1
  
-- for JAR (in case you have another version of Java installed)
$ alternatives --install /usr/bin/jar jar /opt/java/jdk1.8.0_202/bin/jar 1
 
-- for JAVAC (in case you have another version of Java installed)
$ alternatives --install /usr/bin/javac javac /opt/java/jdk1.8.0_202/bin/javac 1
$ alternatives --set javac /opt/java/jdk1.8.0_202/bin/javac
  
$ rm /opt/java/jdk-8u202*.tar.gz

-- setting JAVA variables
 
$ export JAVA_HOME=/opt/java/jdk1.8.0_202
$ export JRE_HOME=/opt/java/jdk1.8.0_202/jre
$ export PATH=$PATH:/opt/java/jdk1.8.0_202/bin:/opt/java/jdk1.8.0_202/jre/bin